const regex = /^(redbook|bluepen|yellowglass)\s(greenapple\spinkglass|pinkglass\sgreenapple)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(redbook|bluepen|yellowglass)\\s(greenapple\\spinkglass|pinkglass\\sgreenapple)$', 'gm')
const str = `bluepen pinkglass greenapple`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}