const regex = /(?'type'A|B|C)-(?|(?'diameter'\d+)x(?'length'\d+)|()(?'length'\d+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'type\'A|B|C)-(?|(?\'diameter\'\\d+)x(?\'length\'\\d+)|()(?\'length\'\\d+))', 'gm')
const str = `A-5
B-6x3
C-79
A-99x1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}