$re = '/(?\'type\'A|B|C)-(?|(?\'diameter\'\d+)x(?\'length\'\d+)|()(?\'length\'\d+))/mJ';
$str = 'A-5
B-6x3
C-79
A-99x1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);