using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{4(?!:)";
string input = @"Hi my {4 name is {4: Jeremy I {4: work in {4 Texas My job is {3 very {0 hard, I work until 4";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}