re = /{4(?!:)/
str = 'Hi my {4 name is {4: Jeremy I {4: work in {4 Texas My job is {3 very {0 hard, I work until 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end