import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:p[0,1][0-9]\\.upd|(downloads|cm\\.k))\\.kaspersky(?(1)-labs)\\.com$";
final String string = "p00.upd.kaspersky.com\n"
+ "p01.upd.kaspersky.com\n"
+ "p02.upd.kaspersky.com\n"
+ "p03.upd.kaspersky.com\n"
+ "p04.upd.kaspersky.com\n"
+ "p05.upd.kaspersky.com\n"
+ "p06.upd.kaspersky.com\n"
+ "p07.upd.kaspersky.com\n"
+ "p08.upd.kaspersky.com\n"
+ "p09.upd.kaspersky.com\n"
+ "p10.upd.kaspersky.com\n"
+ "p11.upd.kaspersky.com\n"
+ "p12.upd.kaspersky.com\n"
+ "p13.upd.kaspersky.com\n"
+ "p14.upd.kaspersky.com\n"
+ "p15.upd.kaspersky.com\n"
+ "p16.upd.kaspersky.com\n"
+ "p17.upd.kaspersky.com\n"
+ "p18.upd.kaspersky.com\n"
+ "p19.upd.kaspersky.com\n"
+ "downloads.kaspersky-labs.com\n"
+ "cm.k.kaspersky-labs.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}