use strict;
my $str = 'p00.upd.kaspersky.com
p01.upd.kaspersky.com
p02.upd.kaspersky.com
p03.upd.kaspersky.com
p04.upd.kaspersky.com
p05.upd.kaspersky.com
p06.upd.kaspersky.com
p07.upd.kaspersky.com
p08.upd.kaspersky.com
p09.upd.kaspersky.com
p10.upd.kaspersky.com
p11.upd.kaspersky.com
p12.upd.kaspersky.com
p13.upd.kaspersky.com
p14.upd.kaspersky.com
p15.upd.kaspersky.com
p16.upd.kaspersky.com
p17.upd.kaspersky.com
p18.upd.kaspersky.com
p19.upd.kaspersky.com
downloads.kaspersky-labs.com
cm.k.kaspersky-labs.com';
my $regex = qr/^(?:p[0,1][0-9]\.upd|(downloads|cm\.k))\.kaspersky(?(1)-labs)\.com$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}