import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(.+?)>([^<>]+)<\\/\\1>";
final String string = "<h1>Nayeem loves counseling</h1>\n"
+ "<h1><h1>Sanjay has no watch</h1></h1><par>So wait for a while</par>\n"
+ "<Amee>safat codes like a ninja</amee>\n"
+ "<SA premium>Imtiaz has a secret crush</SA premium>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}