import re
regex = re.compile(r"<(.+?)>([^<>]+)<\/\1>")
test_str = ("<h1>Nayeem loves counseling</h1>\n"
"<h1><h1>Sanjay has no watch</h1></h1><par>So wait for a while</par>\n"
"<Amee>safat codes like a ninja</amee>\n"
"<SA premium>Imtiaz has a secret crush</SA premium>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")