using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^##(?!#).*(?:\n(?!##(?!#)).*)*";
string input = @"## 8.6.0
- **Upload date:** November 19, 2020
- **Release date:** TBC
- **Internal version:** 1171
### Feature
- dsfdsfds
- sdfdsf
- dsfdsf
### Bug fixes
- sdfsaf
- sdfsad
- sdfsdfdsf
### Internal
- sadfsdfsda
- fsdfgsadfasd
- sdfsda
## 8.5.1
- **Upload date:** November 09, 2020
- **Release date:** November 12, 2020
- **Internal version:** 1170
## 8.7.1
- **Upload date:** November 09, 2020
- **Release date:** November 12, 2020
- **Internal version:** 1170";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}