import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^##(?!#).*(?:\\n(?!##(?!#)).*)*";
final String string = "## 8.6.0\n"
+ "- **Upload date:** November 19, 2020\n"
+ "- **Release date:** TBC\n"
+ "- **Internal version:** 1171\n\n"
+ "### Feature\n"
+ "- dsfdsfds\n"
+ "- sdfdsf\n"
+ "- dsfdsf\n\n"
+ "### Bug fixes\n"
+ "- sdfsaf\n"
+ "- sdfsad\n"
+ "- sdfsdfdsf\n\n"
+ "### Internal\n"
+ "- sadfsdfsda\n"
+ "- fsdfgsadfasd\n"
+ "- sdfsda\n\n"
+ "## 8.5.1\n"
+ "- **Upload date:** November 09, 2020\n"
+ "- **Release date:** November 12, 2020\n"
+ "- **Internal version:** 1170\n\n"
+ "## 8.7.1\n"
+ "- **Upload date:** November 09, 2020\n"
+ "- **Release date:** November 12, 2020\n"
+ "- **Internal version:** 1170";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}