re = /"(test)"\h*:\h*(?|"([^"]*)"|\[([^]]*)])/m
str = '"test":"value0"
"test":["value1", "value2"]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end