$re = '/\bch\D*\K\d+/mi';
$str = '"chapter some word 12"
"chapter some word 12 some word"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);