re = /\bch\D*\K\d+/mi
str = '"chapter some word 12"
"chapter some word 12 some word"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end