package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`clos(e|es|ed|ing)([ ,]*#[0-9]+)+ ?|fix(es|ed|ing)?([ ,]*#[0-9]+)+ ?|resolv(e|es|ed|ing)([ ,]*#[0-9]+)+ ?`)
var str = `This fixes #23 fixed#24 fix #25, #26 resolves #27 #28#29 resolved#30 #31 , #32. Also see #33`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}