$re = '/clos(e|es|ed|ing)([ ,]*#[0-9]+)+ ?|fix(es|ed|ing)?([ ,]*#[0-9]+)+ ?|resolv(e|es|ed|ing)([ ,]*#[0-9]+)+ ?/';
$str = 'This fixes #23 fixed#24 fix #25, #26 resolves #27 #28#29 resolved#30 #31 , #32. Also see #33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);