using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Detalhamento de Serviços.+(\d+-\d+-\d+)";
string input = @"Detalhamento de Serviços nº: 999-99999-9999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}