$re = '/Detalhamento de Serviços.+(\d+-\d+-\d+)/m';
$str = 'Detalhamento de Serviços nº: 999-99999-9999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);