$re = '/[^\/\n]+(?=\/?$)/m';
$str = 'www.url1.com/test
www.url1.com/test2/
www.url1.com/test/sdadas/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);