re = /[^\/\n]+(?=\/?$)/m
str = 'www.url1.com/test
www.url1.com/test2/
www.url1.com/test/sdadas/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end