using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<key>\w+)\.nomv=""|(?!^)(?<=\G)(?<val>.+?)(?:\|\|\||"")";
string input = @"page_name=""xxx.com"", page_type=other, thread_id=1152236, geo_locality.nomv=""Seattle|||San Francisco|||Chicago"", user_reference_count=0,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}