re = /(?<key>\w+)\.nomv="|(?!^)(?<=\G)(?<val>.+?)(?:\|\|\||")/m
str = 'page_name="xxx.com", page_type=other, thread_id=1152236, geo_locality.nomv="Seattle|||San Francisco|||Chicago", user_reference_count=0,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end