$re = '/(\()?((\d+|\((?2)\))([+*](\d+|\((?2)\)))+)(?(1)\))=\d+/';
$str = '(1+1)+1*1+(1*1)+(1*(123+1))=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);