re = /(\()?((\d+|\((?2)\))([+*](\d+|\((?2)\)))+)(?(1)\))=\d+/
str = '(1+1)+1*1+(1*1)+(1*(123+1))=1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end