re = /\[.+?\](?![\.])/
str = 'I am parsing some SQL statements and have found places where the SELECT statement may be:
SELECT [tblCustomer].[FirstName], [tblCustomer.LastName], [tblOrder].[Order_No]
and as you see the second column has a `.` inside the square brackets. This is acceptable in Access SQL but not SQL Server. I\'m trying to build a RegEx to identify when there is a `.` inside square brackets and replace it with `].[`
I\'ve tried: `\\[.+?\\](?![\\.])` which will get me a period inside square brackets but it doesn\'t stop searching when it finds the closing bracket.
I\'m using ECMAScript to be compatible with VBA and I don\'t have concerns about nested brackets.
Another example:
SELECT IIf([tbl_ref_Service].[Root_Service] Is Null,[tbl_ref_Service].[Service],[tbl_ref_Service].[Root_Service]) AS Root_Service, tbl_POC_Assigned.POC_ID, [tbl_POC_Assigned.Hex_ID] & "_" & [tbl_Hex.Generic_ID] & "_" & [tbl_Lateral.Service_ID] & "_" & [tbl_Hex.ODD_Micap] & "_Null" AS Tool_Generic_Line, tbl_Hex.Building_ID AS Hex_Building_ID, tbl_POC.Lateral_ID, tbl_Generic_Service.Peak_Flow, [Diversity_Factor]*[Peak_Flow] AS Avg_Flow, tbl_POC_Assigned.Flow, tbl_POC_Assigned.Flow_Avg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end