import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p class=\"mb-40px\">(?:<.+?>|\\s)+?</p>\\R*";
final String string = "<p class=\"mb-40px\"></g></svg> </a>\n"
+ " </li>\n"
+ " \n"
+ " \n"
+ " \n"
+ " </ul>\n"
+ " </div>\n\n"
+ " \n\n"
+ " \n"
+ " </div>\n"
+ " \n"
+ " </div>\n"
+ " \n"
+ " </div>\n"
+ " </div>\n"
+ " \n"
+ " </div>\n"
+ " </div>\n\n\n"
+ " <div class=\"comment-form-fields\">\n"
+ " <input type=\"hidden\" name=\"wp_avatar\" id=\"wordpress-avatar\" class=\"comment-meta-wordpress\" value=\"\" />\n"
+ " <input type=\"hidden\" name=\"wp_user_id\" id=\"wordpress-user_id\" class=\"comment-meta-wordpress\" value=\"\" />\n"
+ " <input type=\"hidden\" name=\"wp_access_token\" id=\"wordpress-access_token\" class=\"comment-meta-wordpress\" value=\"\" />\n"
+ " <p class=\"comment-form-posting-as pa-wordpress\">\n"
+ " \n"
+ " Comentezi folosind contul tău WordPress.com. <span class=\"comment-form-log-out\">\n"
+ " ( <a href=\"javascript:HighlanderComments.doExternalLogout( 'wordpress' );\">Dezautentificare</a> / \n"
+ " <a href=\"#\" onclick=\"javascript:HighlanderComments.switchAccount();return false;\">Schimbă</a> )\n"
+ " </span>\n"
+ " \n"
+ " </p>\n"
+ "<p class=\"mb-40px\">\n"
+ " \n"
+ " Comentezi folosind contul tău Google. <span class=\"comment-form-log-out\">\n"
+ " ( <a href=\"javascript:HighlanderComments.doExternalLogout( 'googleplus' );\">Dezautentificare</a> / \n"
+ " <a href=\"#\" onclick=\"javascript:HighlanderComments.switchAccount();return false;\">Schimbă</a> )\n"
+ " </span>\n"
+ " \n"
+ " </p>\n"
+ "<p class=\"mb-40px\">\n"
+ " \n"
+ " Comentezi folosind contul tău Twitter. <span class=\"comment-form-log-out\">\n"
+ " ( <a href=\"javascript:HighlanderComments.doExternalLogout( 'twitter' );\">Dezautentificare</a> / \n"
+ " <a href=\"#\" onclick=\"javascript:HighlanderComments.switchAccount();return false;\">Schimbă</a> )\n"
+ " </span>\n"
+ " \n"
+ " </p>\n"
+ "<p class=\"mb-40px\">\n"
+ " \n"
+ " Comentezi folosind contul tău Facebook. <span class=\"comment-form-log-out\">\n"
+ " ( <a href=\"javascript:HighlanderComments.doExternalLogout( 'facebook' );\">Dezautentificare</a> / \n"
+ " <a href=\"#\" onclick=\"javascript:HighlanderComments.switchAccount();return false;\">Schimbă</a> )\n"
+ " </span>\n"
+ " \n"
+ " </p>\n"
+ " \n"
+ " <p class=\"mb-40px\">Foarte frumos lucru</p>\n"
+ "<p class=\"mb-40px\">I love cars</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}