$re = '/^(?:.{6}657|.{15}657)/m';
$str = '00000000000008165736
RF77706578000000000543278
000000000000008165736
RF777006578000000000543278';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);