re = /^(?:.{6}657|.{15}657)/m
str = '00000000000008165736
RF77706578000000000543278
000000000000008165736
RF777006578000000000543278'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end