package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^cron\(([\W\w\D\d]+)\)$`)
var str = `cron(* * * ? * * *)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}