$re = '/^cron\(([\W\w\D\d]+)\)$/m';
$str = 'cron(* * * ? * * *)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);