use strict;
my $str = 'CapitalCaseWords';
my $regex = qr/(?<=[a-z])(?=[A-Z])/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";