$re = '/(?<=[a-z])(?=[A-Z])/m';
$str = 'CapitalCaseWords';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;