const regex = /^(?<client>.*)###(?<company>[^_]*)_(?<typology>[^_]*)_(?<period>[^_]*)_(?<uid>ID\d*)\.PdV$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<client>.*)###(?<company>[^_]*)_(?<typology>[^_]*)_(?<period>[^_]*)_(?<uid>ID\\d*)\\.PdV$', 'gmi')
const str = `0587###02511020162_LG_2019M01_ID4.PdV`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}