$re = '/(?:\'(.+?)(?<!\\\\)\')/';
$str = 'server (\'m1.labs.teradata.com\') username (\'u\\\'se)r_*5\') password(\'uer5\') dbname (\'default\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);