import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\|)\\R(?!\\|[ \\t]+\\d+[ \\t]+\\|)";
final String string = "| 1020941333 | 569|SP |500000343 | 9|18.05.2011|15:27:00|18.05.2011|\n"
+ "18.05.2011|Y-0444871-ENCR | 1,93 |BRL |8000800000 |\n"
+ "Juros, Comissões e T | | |\n"
+ " | | | |\n"
+ " |CLB082902 | | | |COEL |COEL |\n"
+ "Y-0444871 |\n"
+ "| 1020941586 | 43|SP |500000344 |43|18.05.2011|15:41:43|18.05.2011|\n"
+ "18.05.2011|B-0447039-ENCR | 9,02 |BRL |8000800000 |\n"
+ "Juros, Comissões e T | | |\n"
+ " | | | |\n"
+ " |CLB082902 | | | |COEL |COEL |\n"
+ "B-0447039 |";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}