# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\|)\R(?!\|[ \t]+\d+[ \t]+\|)"
test_str = ("| 1020941333 | 569|SP |500000343 | 9|18.05.2011|15:27:00|18.05.2011|\n"
"18.05.2011|Y-0444871-ENCR | 1,93 |BRL |8000800000 |\n"
"Juros, Comissões e T | | |\n"
" | | | |\n"
" |CLB082902 | | | |COEL |COEL |\n"
"Y-0444871 |\n"
"| 1020941586 | 43|SP |500000344 |43|18.05.2011|15:41:43|18.05.2011|\n"
"18.05.2011|B-0447039-ENCR | 9,02 |BRL |8000800000 |\n"
"Juros, Comissões e T | | |\n"
" | | | |\n"
" |CLB082902 | | | |COEL |COEL |\n"
"B-0447039 |")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.