using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:[^\d\n]*\d){2}).*";
string input = @"a 1 b 2 c
1 b 2 c
a 1 b 2
a 1 b 2 c 3 d 4 e
a 12
12 a b c
a 1 b
1
a b 2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}