import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:[^\\d\\n]*\\d){2}).*";
final String string = "a 1 b 2 c\n"
+ "1 b 2 c\n"
+ "a 1 b 2\n"
+ "a 1 b 2 c 3 d 4 e\n"
+ "a 12\n"
+ "12 a b c\n\n"
+ "a 1 b\n"
+ "1\n"
+ "a b 2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}