package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\S+ \/\/ (\S+)`)
var str = `abc // ghj // kbc // asd.g // 234 // gg
bhx // adj // mkf // fg.bhx
bhs // jk
---
aghd
abd // ghh // 786
Ak8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}