$re = '/^\S+ \/\/ (\S+)/m';
$str = 'abc // ghj // kbc // asd.g // 234 // gg
bhx // adj // mkf // fg.bhx
bhs // jk
---
aghd
abd // ghh // 786
Ak8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);