import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\s+\\K.*";
final String string = " <div class=\"p13n-sc-truncate p13n-sc-truncated-hyphen p13n-sc-line-clamp-2\" aria-hidden=\"true\" data-rows=\"2\" data-truncate-mix-weblab='true'>\n\n"
+ " LG 32MA68HY-P 32-Inch IPS Monitor with Display Port and HDMI Inputs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}