# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\K\s*(?:(\/)\s+)?|\s+(?=>)/$1/gm;t' <<< "<p > ¡Esto es una prueba! < /p > <p> <strong > Prueba 123 </strong> </p> <p> <strong> < a href=\"https://matricom.net\"> MATRICOM < / a> </ strong> </p> <p> <strong > Todas las pruebas aquí ... </strong > < /p> <img/ >
<p> ¡Esto es una prueba! </p> <p> <strong> Prueba 123 </strong> </p> <p> <strong> <a href=\"https://matricom.net\"> MATRICOM </a> </strong> </p> <p> <strong> Todas las pruebas aquí ... </strong> </p> <img/>"