using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\K\s*(?:(/)\s+)?|\s+(?=>)";
string substitution = @"$1";
string input = @"<p > ¡Esto es una prueba! < /p > <p> <strong > Prueba 123 </strong> </p> <p> <strong> < a href=""https://matricom.net""> MATRICOM < / a> </ strong> </p> <p> <strong > Todas las pruebas aquí ... </strong > < /p> <img/ >
<p> ¡Esto es una prueba! </p> <p> <strong> Prueba 123 </strong> </p> <p> <strong> <a href=""https://matricom.net""> MATRICOM </a> </strong> </p> <p> <strong> Todas las pruebas aquí ... </strong> </p> <img/>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}