#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[a-z]+\d*[-_])+[a-z]+\d*(?:_64)?)"
Local $sString = "kernel-debug-modules-extra-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"kernel-debug2-modules-extra-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"kernel-debug-modules2-extra-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"kernel-debug-modules-extra2-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"kernel-debug-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"kernel-debug-core-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"kernel-debug-devel-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"kernel-debug-modules-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"python3-perf-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"python3-perf2-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"kernel-debuginfo-common-x86_64-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"kernel_debuginfo_common-x86_64-4.18.0-80.2.el8.x86_64.rpm" & @CRLF & _
"----" & @CRLF & _
"desired output (exlude words which starts with hypen and digit (-4.xxx) and exclude -x86_64):" & @CRLF & _
"kernel-debug-modules-extra" & @CRLF & _
"kernel-debug2-modules-extra" & @CRLF & _
"kernel-debug-modules2-extra" & @CRLF & _
"kernel-debug-modules-extra2" & @CRLF & _
"kernel-debug" & @CRLF & _
"kernel-debug-core" & @CRLF & _
"kernel-debug-devel" & @CRLF & _
"kernel-debug-modules" & @CRLF & _
"python3-perf" & @CRLF & _
"python3-perf2" & @CRLF & _
"kernel-debuginfo-common" & @CRLF & _
"kernel_debuginfo_common"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")