use strict;
my $str = 'kernel-debug-modules-extra-4.18.0-80.2.el8.x86_64.rpm
kernel-debug2-modules-extra-4.18.0-80.2.el8.x86_64.rpm
kernel-debug-modules2-extra-4.18.0-80.2.el8.x86_64.rpm
kernel-debug-modules-extra2-4.18.0-80.2.el8.x86_64.rpm
kernel-debug-4.18.0-80.2.el8.x86_64.rpm
kernel-debug-core-4.18.0-80.2.el8.x86_64.rpm
kernel-debug-devel-4.18.0-80.2.el8.x86_64.rpm
kernel-debug-modules-4.18.0-80.2.el8.x86_64.rpm
python3-perf-4.18.0-80.2.el8.x86_64.rpm
python3-perf2-4.18.0-80.2.el8.x86_64.rpm
kernel-debuginfo-common-x86_64-4.18.0-80.2.el8.x86_64.rpm
kernel_debuginfo_common-x86_64-4.18.0-80.2.el8.x86_64.rpm
----
desired output (exlude words which starts with hypen and digit (-4.xxx) and exclude -x86_64):
kernel-debug-modules-extra
kernel-debug2-modules-extra
kernel-debug-modules2-extra
kernel-debug-modules-extra2
kernel-debug
kernel-debug-core
kernel-debug-devel
kernel-debug-modules
python3-perf
python3-perf2
kernel-debuginfo-common
kernel_debuginfo_common';
my $regex = qr/^(?:(?:[a-z]+\d*[-_])+[a-z]+\d*(?:_64)?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}