import re
regex = re.compile(r"^\$?(?:\d+|\d*\.\d+|(?:\d{1,3},)?(?:\d{3},)*\d{3}|(?:\d{1,3},)?(?:\d{3},)*\d{3}\.\d+)$", flags=re.MULTILINE | re.UNICODE)
test_str = ("1\n"
"123\n"
"1234567\n"
"1234567890\n"
"1,234\n"
"123,456\n"
"1,234,567\n"
"1,234,567,890\n"
"$1\n"
"$123\n"
"$1234567.890\n"
"$1234567890\n"
"$1,234\n"
"$123,456\n"
"$1,234,567\n"
"1.0\n"
"123.0\n"
"1234567.0\n"
"1,234.0\n"
"123,456.0\n"
"1,234,567.0\n"
"$1.0\n"
"$123.0\n"
"$123456.0\n"
"$1,234.0\n"
"$123,456.0\n"
"$1,234,567.987\n"
".0\n"
"$.0\n"
".01\n"
"$.02\n\n"
" 1 12\n"
"1,23\n"
"1,234567\n"
"$\n"
"$,0\n"
"$1,0\n"
"1.1.1\n"
"1.\n"
".\n"
"1,1\n"
",1\n"
"1,1.0\n"
"1.1,0\n"
",")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")