re = /^\$?(?:\d+|\d*\.\d+|(?:\d{1,3},)?(?:\d{3},)*\d{3}|(?:\d{1,3},)?(?:\d{3},)*\d{3}\.\d+)$/m
str = '1
123
1234567
1234567890
1,234
123,456
1,234,567
1,234,567,890
$1
$123
$1234567.890
$1234567890
$1,234
$123,456
$1,234,567
1.0
123.0
1234567.0
1,234.0
123,456.0
1,234,567.0
$1.0
$123.0
$123456.0
$1,234.0
$123,456.0
$1,234,567.987
.0
$.0
.01
$.02
1 12
1,23
1,234567
$
$,0
$1,0
1.1.1
1.
.
1,1
,1
1,1.0
1.1,0
,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end