#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\h\K\d{10,}[^']*"
Local $sString = "'Firstname Lastname lorem@gmail.com 0000243598 CAB pilote 001 001'," & @CRLF & _
"'Firstname Lastname lorem@gmail.com 0000243598 CAB pilote 001 001'," & @CRLF & _
"'Firstname Lastname lorem@gmail.com 0000243598 0000243598 CAB pilote 001 001'," & @CRLF & _
"'Firstname Lastname lorem@gmail.com 0000243598 0000243598 CAB pilote 001 001',"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")