re = /.*\h\K\d{10,}[^']*/m
str = '\'Firstname Lastname lorem@gmail.com 0000243598 CAB pilote 001 001\',
\'Firstname Lastname lorem@gmail.com 0000243598 CAB pilote 001 001\',
\'Firstname Lastname lorem@gmail.com 0000243598 0000243598 CAB pilote 001 001\',
\'Firstname Lastname lorem@gmail.com 0000243598 0000243598 CAB pilote 001 001\','
# Print the match result
str.scan(re) do |match|
puts match.to_s
end