$re = '/(?:^\s*func\s(display\w*)\(\)$)/m';
$str = 'protocol SceneDisplayView {
func displayEmailScreen()
func displayPasswordScreen()
func displayNameScreen()
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);